Code Yarns ‍👨‍💻
Tech BlogPersonal Blog

Artifact file not found error with NVIDIA NSight

📅 2014-Jun-25 ⬩ ✍️ Ashwin Nanjappa ⬩ 📚 Archive

Problem

I tried to install the Vrapper plugin to NVIDIA NSight. Everything went fine until the last step, which gave this error:

An error occurred while installing the items
session context was:(profile=cider, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.equinox.launcher.gtk.linux.x86_64 1.1.200.v20120913-144807, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.equinox.launcher.gtk.linux.x86_64,1.1.200.v20120913-144807 was not found.

Solution

Go to ~/.eclipse. One of the subdirectories here holds the configuration files for NSight. The other subdirectory might be for Eclipse, if you have installed it and are using it. Delete the NSight subdirectory. Open NSight again and try installing Vrapper. It worked this time for me.

Tried with: Vrapper 0.44, NVIDIA NSight 5.5 and Ubuntu 14.04