Diodon not copying to its clipboard


I have Diodon working fine on a Ubuntu 14.04 computer. But, when I tried it on a Ubuntu 15.04 computer, it would not work. It is running, but nothing I copy is appearing in its clipboard, which remains empty!


The newer version of Diodon now uses the Zeitgeist service for tracking what is copied by the user. This is described in this blog post. I usually turn off all logging of file and application use on Ubuntu and this is nothing but the Zeitgeist service.

To minimally turn back Zeitgeist just enough for Diodon to work, go to System Settings -> Security and Privacy -> File and Applications. Turn ON the Record file and application usage option and include Documents. The rest can be disabled, they are not needed.

Restart Diodon and it should now work as expected.

Tried with: Diodon 1.2.0 and Ubuntu 15.04

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s