How to build and install FLTK 2.0

FLTK 2.0 is an experimental new version of the library that was later abandoned. Some other libraries seem to use it, so sometimes you may need to build and install it. Doing that is easy:

  • Download the source code from the SVN repository:
$ svn co http://seriss.com/public/fltk/fltk/trunk fltk-2.0

If it asks for username or password, just press Enter.

  • Configure and build the code:
$ cd fltk-2.0
$ autoconf
$ ./configure
$ make
  • You might get this error:
=== making test ===
Compiling mandelbrot_ui.cxx...
In file included from mandelbrot_ui.cxx:3:0:
mandelbrot_ui.h:15:5: error: β€˜Drawing_Area’ does not name a type

Open Makefile and remove test from this line:

DIRS = src $(LOCALIMAGES) images OpenGL fluid glut test
  • Build again, it should succeed. Install the files:
$ make
$ sudo make install

Tried with: Ubuntu 12.04 LTS

Advertisements

4 thoughts on “How to build and install FLTK 2.0

  1. Hi, I downloaded the source code from the svn repository, but when I input the command autoconf it says
    bash: autoconf: command not found
    and the same for the ./configure command
    Any suggestion?

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.